Submitting Support Cases through Parchment Help Center
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Jul 20, 2023 - 14:47 PDT
Investigating
We are investigating an issue that is preventing administrators from submitting a support case when logged in to their Parchment administrator account.
While we work to address the root cause, there is a work around. Adding your email to the cc: field should allow the case to be submitted. We apologize for the inconvenience. We do not intend for the cc: field to be required in the long term. This is a temporary workaround.
You can also reach us at 888-662-0874 (admins only, please no learners)
Please do not submit a web case through the learner help center. Please either add a cc: to allow your web case to be submitted from the admin help center, or call us for assistance.
Posted Feb 17, 2023 - 12:10 PST
This incident affected: Consumer (Login, Ordering), Integrations (Ellucian eTranscripts, eScrip-Safe Printer, RoboRegistrar), and Parchment Award - Transcript Services, Parchment Award - Diploma, Certificate, Badge, CLR, Parchment Analyze/Recruit.