Company Wide Meeting (11/14)
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 15:05 PST
Identified
Administrative Phone Support will be temporarily unavailable from 4:45 PM CST - 6:00 PM CST today for a company meeting. We apologize for the inconvenience. We will respond to your inquiry as soon as possible.
Posted Nov 14, 2023 - 13:55 PST
This incident affected: Supporting Services (Parchment Support).