Issues with T+ Order Form
Incident Report for Parchment
Resolved
All processes related to ordering through TranscriptsPlus have been fully restored. Any fees that were incorrectly applied to orders will be returned to the requestor. There is no need to contact Parchment on behalf of requestors. We are working through that process now. Thank you for your patience.
Posted Jun 23, 2022 - 12:01 PDT
Investigating
We are aware of issues with the TranscriptsPlus order form including inability to e-sign the FERPA Authorization and other inconsistencies. We are investigating and will provide an update as soon as it is available.
Posted Jun 23, 2022 - 07:18 PDT
This incident affected: Credentials Solutions (TranscriptsPlus).