Issues with www.parchment.com and ordering
Incident Report for Parchment
Resolved
At this time our web hosting partner is reporting that the issue impacting www.parchment.com pages has been resolved. Thank you
Posted Sep 14, 2023 - 13:28 PDT
Identified
We have identified the issue impacting some pages on www.parchment.com and it is related to an incident being managed by our web hosting partner. Students can still place orders and check status of orders by following the links to log in / create an account.
We will continue to provide updates as they are available.
Posted Sep 14, 2023 - 11:19 PDT
Investigating
We are aware of and investigating issues with www.parchment.com and the ordering workflow. We will provide an update when it is available.
Posted Sep 14, 2023 - 10:17 PDT
This incident affected: Consumer (Login, Ordering).