Upcoming Holiday Closure: Memorial Day 2023
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted May 30, 2023 - 11:51 PDT
Update
We are continuing to investigate this issue.
Posted May 18, 2023 - 07:52 PDT
Investigating
Parchment will be closed on Monday May 29, 2023. We will reopen and resume support and print operations services on Tuesday May 30th.
Posted May 18, 2023 - 07:48 PDT
This incident affected: Parchment Award - Transcript Services, Parchment Award - Diploma, Certificate, Badge, CLR and Supporting Services (Parchment Print, Parchment Support).