Parchment Closed Tuesday July 4, 2023
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Jul 05, 2023 - 07:23 PDT
Investigating
Parchment will be closed on Tuesday July 4, 2023. We will reopen at 8am EST on Wednesday July 5, 2023.
Posted Jun 26, 2023 - 06:53 PDT
This incident affected: Consumer (Login, Ordering, Payment / JPMChase) and Parchment Award - Transcript Services, Parchment Award - Diploma, Certificate, Badge, CLR, Parchment Analyze/Recruit, Course and Credit Solutions (Quottly) - Web Application, Course and Credit Solutions (Quottly) - Integration.