TranscriptsPlus USPS Scan Data
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 13:54 PDT
Monitoring
We have been actively working to resolve an issue related to our shipping partner's process and our connection to USPS data, both of which were preventing USPS scan details from being reported to us for Credentials Solutions TranscriptsPlus mail for the past several months. We are now seeing USPS scans returned more consistently; in turn you and your students should begin to see more USPS scan data indicating where each mailed piece is in its journey. We appreciate your patience as we have worked through these issues.
Posted Sep 14, 2021 - 08:00 PDT