Member Services Department Meeting
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Jun 09, 2023 - 12:49 PDT
Identified
Administrative Phone Support will be temporarily unavailable from 12:45 PM CST - 2:00 PM CST today for a department meeting. We apologize for the inconvenience. We will respond to your inquiry as soon as possible.
Posted Jun 09, 2023 - 07:42 PDT
This incident affected: Supporting Services (Parchment Support).