Student Verification Codes Delayed
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Jul 14, 2022 - 12:35 PDT
Investigating
We are investigating an issue that is resulting in failure to deliver verification codes to students registering for a new account at www.parchment.com At this time we do not have a workaround and would ask that students allow time for us to resolve this issue before trying again.
Posted Jul 14, 2022 - 12:06 PDT
This incident affected: Parchment 7 (Learner (Login, Registration & Ordering)) and Parchment Award.