Parchment Support Phones Unavailable
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Jun 15, 2023 - 16:53 PDT
Identified
Our phone provider, Five9 is currently experiencing issues. We do not have an estimated timeframe as to when this will be resolved. Thank you for your patience.
Posted Jun 15, 2023 - 15:14 PDT
This incident affected: Parchment Award - Transcript Services, Parchment Award - Diploma, Certificate, Badge, CLR, and Parchment Analyze/Recruit.