Possible FAX interruption (TranscriptsPlus only)
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Apr 29, 2022 - 12:55 PDT
Identified
Due to the need to perform critical infrastructure maintenance FAX service may be interrupted briefly / intermittently today, Friday 4/29/22.
Posted Apr 29, 2022 - 11:55 PDT
This incident affected: Credentials Solutions (TranscriptsPlus).