TransciptsPlus Support Unavailable Friday 1/7/22 as of 1:20pm CST
Incident Report for Parchment
Resolved
We believe the issues impacting our access to TranscriptsPlus support tools have been resolved. The phone lines have been turned back on. Please note that we are experiencing significantly higher than usual phone volume. T+ users can also get assistance by visiting www.parchment.com/chat-support where they have the option to review frequently asked questions, submit a web case, or chat live with an agent. There is a link to this website on the bottom of the T+ order form labeled "Customer Service." Thank you for your patience.
Posted Jan 07, 2022 - 12:17 PST
Identified
Due to an intermittent outage affecting internal support tools necessary for aiding Transcripts Plus callers, we are unable to take Transcripts Plus support calls at this time. Our phone system has been set to play a temporary outage greeting. The actual Transcripts Plus application and ordering process is unaffected and fully operational. Students can submit a web case at www.parchment.com/support however until our internal tool access has been fully restored by our 3rd party partner we will be unable to investigate and assist with support inquiries. This issue also impacts our ability to assist T+ administrators however phones remain open for admins.
Posted Jan 07, 2022 - 11:25 PST
This incident affected: Credentials Solutions (TranscriptsPlus).