Course and Credit Solutions (Quottly) Support Channel Outage
Incident Report for Parchment
Resolved
Live Chat support has been restored. We appreciate your patience.
Posted Jul 19, 2023 - 06:59 PDT
Investigating
At this time we are unable to provide support for Course and Credit Solutions (Quottly) users via Live Chat. Our team is still available to assist via email and phone 844-326-7030
We are working to restore access to Live Chat and will provide an update when we are able.
Posted Jul 17, 2023 - 08:24 PDT
This incident affected: Course and Credit Solutions (Quottly) - Web Application and Course and Credit Solutions (Quottly) - Integration.