RoboRegistrar orders in use or in process
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 09:16 PST
Investigating
We are currently investigating reports of orders stuck in use or in a processing status. This should be resolved shortly.
Posted Nov 15, 2022 - 07:39 PST
This incident affected: Credentials Solutions (TranscriptsPlus).