Delay in Print & Mail Diploma Services
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Nov 22, 2021 - 07:45 PST
Identified
Due to staffing shortages within Parchment's Print Operations we are currently delayed in processing diploma requests (both for new issuances, and for reprints / release from hold on prior issuances). We are working to bring our production back within our standard level of service. At this time Members and Graduates should expect up to a 10 day delay on processing. We apologize for the inconvenience and are working to improve processes to avoid similar delays in the future.
Posted Oct 07, 2021 - 13:57 PDT
This incident affected: Parchment Award - Diploma, Certificate, Badge, CLR.