Parchment Closed Monday June 19, 2023
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Jun 20, 2023 - 05:24 PDT
Investigating
Parchment will be closed on Monday, June 19, 2023. Support, print operations, and other functions will resume on Tuesday June 20th.
Posted Jun 12, 2023 - 07:09 PDT
This incident affected: Consumer (Login, Ordering, Payment / JPMChase), Integrations (Ellucian eTranscripts, eScrip-Safe Printer, RoboRegistrar), Supporting Services (FedEx, USPS, Parchment Print, Parchment Support, Salesforce / Parchment Help Center, GlobalSign), and Parchment Award - Transcript Services, Parchment Award - Diploma, Certificate, Badge, CLR, Parchment Analyze/Recruit.