Digital Diploma Social Media Sharing
Incident Report for Parchment
Resolved
Digital Diplomas issued through Parchment can once again be shared on Facebook. Thank you for your patience.
Posted Jun 29, 2022 - 15:23 PDT
Investigating
We are aware that currently digital diplomas cannot be shared on Facebook. We are working to resolve this issue.
Posted Jun 27, 2022 - 07:03 PDT
This incident affected: Parchment Award - Diploma, Certificate, Badge, CLR.