Company Wide Meeting (10/30) - Admin Phone Support Unavailable (2:15 PM CST - 3:00 PM CST)
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Oct 30, 2023 - 13:16 PDT
Identified
Administrative Phone Support will be temporarily unavailable from 2:15 PM CST - 3:00 PM CST today for a company meeting. However during this time, Learners WILL still be able to reach out to our support team.

We will respond to your inquiry as soon as possible. We apologize for the inconvenience.
Posted Oct 30, 2023 - 10:30 PDT
This incident affected: Supporting Services (Parchment Support).