Slow login times

Incident Report for Parchment Inc

Resolved

This incident has been resolved and we will continue to monitor login times.
Posted May 11, 2026 - 19:16 UTC

Investigating

We are currently investigating slow login times that sometimes results in an error. Please try again if you receive this error.
Posted May 11, 2026 - 16:40 UTC
This incident affected: Consumer (Login) and Parchment Award - Transcript Services, Parchment Award - Diploma, Certificate, Badge, CLR, Parchment Analyze/Recruit.