Seasonal volume: Transcript Order Processing

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 01:35 UTC

Monitoring

Due to seasonal transcript order volumes, please allow extra time for the application to process your institution's transcript orders. While you may notice a delay, the application is operational and processing requests. Orders will clear out of the processing queues throughout the day.
Posted Jun 02, 2025 - 19:45 UTC
This incident affected: Parchment Award - Transcript Services.