404 Error - Downloading Third Party PDFs issued from GED Jurisdictions

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 17:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2026 - 17:26 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 04, 2026 - 16:55 UTC

Investigating

We're currently investigating reports of recipients receiving a 404 error when attempting to download third-party PDFs issued from GED jurisdictions. We'll provide an update as soon as we have more information.
Posted Jun 04, 2026 - 16:18 UTC
This incident affected: Parchment Award - Transcript Services.