Unable to web download documents through Parchment Receive

Incident Report for Parchment Inc

Resolved

This incident is resolved.
Posted May 01, 2026 - 18:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 01, 2026 - 17:04 UTC

Investigating

We are currently investigating reports of errors when attempting to download documents manually in Parchment Receive.
Posted May 01, 2026 - 16:09 UTC
This incident affected: Parchment Award - Transcript Services.