Award Order Processing Delays

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 20:20 UTC

Investigating

We are investigating an issue where submitted orders are experiencing a delay in processing, we will provide more information as it becomes available.
Posted Mar 16, 2026 - 18:21 UTC
This incident affected: Parchment Award - Transcript Services and Parchment Award - Diploma, Certificate, Badge, CLR.