Order Status Discrepancy
Incident Report for Parchment
Resolved
This issue has been resolved. Thank you for your patience.
Posted Jul 29, 2022 - 07:00 PDT
Investigating
Some orders from 7/26 and 7/27 may show an incorrect status on the To Do list or in History. Any processed orders have completed, however their status may appear to be incorrect, which may include them remaining on the To Do list. We are currently working to correct this discrepancy.
Posted Jul 28, 2022 - 09:56 PDT
This incident affected: Parchment 7 (Administrator (Login & Processing)).