Credentials-inc.com Connectivity Issues

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted May 01, 2025 - 08:05 UTC

Identified

We have identified the issue to be a hardware problem causing the backing system to be unable function. We are working to resolve the issue as quickly as possible and will provide updates as progress is made.
Posted May 01, 2025 - 04:45 UTC

Investigating

We are aware of and investigating and issues with credentials-inc.com, affecting RoboRegistrar traffic.
Posted May 01, 2025 - 01:57 UTC
This incident affected: Integrations (RoboRegistrar).