Brief system update to improve our School Search on Parchment.com

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 21:47 UTC

Update

Today at 5:00 PM EDT there is a brief system update to improve our School Search on our Parchment.com website. While we don't expect it, you may experience a momentary interruption lasting just a few minutes.
Posted Jul 30, 2026 - 20:20 UTC

Monitoring

Today at 5:00 PM EDT there is a brief system update to improve our School Search on our Parchment.com website.  While we don't expect it, you may experience a momentary interruption lasting just a few minutes.
Posted Jul 30, 2026 - 20:17 UTC
This incident affected: Consumer (Login, Ordering, Payment / JPMChase).