Email Delivery Delays
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted May 23, 2023 - 13:33 PDT
Monitoring
Email delivery has resumed. Please allow some time for all messages to be delivered.
Posted May 23, 2023 - 12:55 PDT
Investigating
We are investigating delays in delivery of Parchment emails, including verification codes and download links.
Posted May 23, 2023 - 12:20 PDT
This incident affected: Consumer (Login) and Parchment Award - Transcript Services, Parchment Award - Diploma, Certificate, Badge, CLR.