Parchment Closed Monday 1/16
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 12:57 PST
Monitoring
Parchment will be closed Monday January 16, 2023 in observance of Dr. Martin Luther King, Jr. Day. There will be no transcripts or diplomas mailed on this day, and support will be unavailable. We will reopen on Tuesday January 17.
Posted Jan 10, 2023 - 13:01 PST
This incident affected: Consumer (Login, Ordering), Integrations (Ellucian eTranscripts, eScrip-Safe Printer, RoboRegistrar), and Parchment Award - Transcript Services, Parchment Award - Diploma, Certificate, Badge, CLR, Parchment Analyze/Recruit.