Slow Order Processing

Incident Report for Parchment Inc

Resolved

After monitoring an applied fix, performance has been stable for the past several hours. Order processing is operating nominally.
Posted Oct 27, 2025 - 19:22 UTC

Investigating

We are investigating a potential issue with the Parchment service where orders are slowly processing, more information will be shared here as it becomes available.
Posted Oct 27, 2025 - 14:29 UTC
This incident affected: Consumer (Ordering).