Delayed Order Fulfillment

Incident Report for Parchment Inc

Resolved

All backlogged orders have been processed and new orders are being fulfilled as expected.
Posted Dec 01, 2025 - 21:25 UTC

Monitoring

We have implemented a fix and see orders from earlier in the day beginning to process. We anticipate that things will return to normal within the next 2 hours at current rates.
Posted Dec 01, 2025 - 19:46 UTC

Investigating

We are investigating an issue where orders are appearing as delayed or unprocessed in our systems, we will post more information as it becomes available.
Posted Dec 01, 2025 - 16:56 UTC
This incident affected: Consumer (Ordering).