5-14-2024: Company Wide Meeting
Incident Report for Parchment Inc
Resolved
This incident has been resolved.
Posted May 15, 2024 - 14:02 UTC
Identified
Administrative Phone Support will be temporarily unavailable from 4:45 PM CST - 6:15 PM CST for a company meeting. We apologize for the inconvenience. We will respond to your inquiry as soon as possible.
Posted May 14, 2024 - 03:48 UTC
This incident affected: Supporting Services (Parchment Support).