Unable to edit recipient details in Diploma Services.
Incident Report for Parchment Inc
Resolved
This incident has been resolved.
Posted Jul 24, 2024 - 17:24 UTC
Investigating
We are currently investigating an error that occurs when you try to edit a recipients details.
Posted Jul 24, 2024 - 14:26 UTC
This incident affected: Parchment Award - Diploma, Certificate, Badge, CLR.