Parchment Print & Mail Delayed One Business Day 1/6/2025

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Jan 08, 2025 - 18:10 UTC

Update

We are continuing to monitor for any further issues.
Posted Jan 07, 2025 - 15:35 UTC

Monitoring

Due to extreme weather conditions affecting Parchment Print Operations there will be no outgoing mail (transcripts or diplomas) on 1/6/2025. We expect to resume normal operations on 1/7/2025.
Posted Jan 06, 2025 - 15:15 UTC
This incident affected: Supporting Services (Parchment Print).