Parchment Phone Support - Intermittent Issues resulting in stalled routing of calls

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 18:32 UTC

Monitoring

Our service provider has implemented a fix and are monitoring the results.
Posted Jul 10, 2025 - 20:06 UTC

Investigating

We have been notified that a portion of callers are unable to proceed through our contact center phone prompts. We have contacted our service provider in order for them to assist with this investigation. We apologize for any inconvenience this may cause.
Posted Jul 09, 2025 - 16:55 UTC
This incident affected: Supporting Services (Parchment Support).