Member Ordering Degraded

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 22:15 UTC

Monitoring

We are aware of an issue where some orders are slow to fulfill or timing out on the member ordering dashboard. We are currently monitoring if the situation.
Posted Feb 27, 2026 - 20:18 UTC
This incident affected: Consumer (Ordering).