Phone System Upgrade October 31st
Incident Report for Parchment Inc
Resolved
Our phone system upgrade has been completed and support is now available.
Posted Oct 31, 2024 - 19:40 UTC
Investigating
On Thursday, October 31st, we will be upgrading our phone system and as a result, phone support will be unavailable starting at 1:15 PM EDT through the remainder of the business day. Administrators may submit your support inquiries to our team through the support link within the Parchment applications. Learners and third parties may be directed to our learner chat support page at https://www.parchment.com/chat-support to review help articles, chat with an agent or submit a support inquiry.
Posted Oct 28, 2024 - 18:08 UTC
This incident affected: Supporting Services (Parchment Support).