November Holidays and Closures
Incident Report for Parchment
Investigating
Parchment will be CLOSED on Thursday 11/24/2022 and Friday 11/25/2022. We will reopen on Monday 11/28/2022.

UPDATE: Parchment employees from around the world will gather in Arizona for a company-wide training and end of year celebration December 7-9. As a result, the following Parchment Support services will be impacted:
Parchment Learner Support: phone support will be unavailable 12/7-12/9. Learners can contact support via chat and web case at www.parchment.com/chat-support. There may be some delays in response.
Parchment Administrator Support: There may be some delays in response 12/7-12/9. We appreciate your patience.
There will be no disruption to Parchment Print & Mail operations during this time period.
Posted Nov 09, 2022 - 09:47 PST
This incident affects: Consumer (Learner (Login, Registration & Ordering), Administrator (Login & Processing)), Integrations (SPEEDE Integration, SFTP Downloads, SFTP Services (Outbound/Inbound)), Parchment 6 (Administrator (Login & Processing)), Credentials Solutions (TranscriptsPlus, eScrip-Safe), Parchment 7 (Administrator (Login & Processing), Learner (Login, Registration & Ordering)), and Parchment Analyze, Parchment Award.