Parchment Closed 9/2
Incident Report for Parchment Inc
Resolved
This incident has been resolved.
Posted Sep 03, 2024 - 14:02 UTC
Investigating
Parchment will be closed Monday, September 2, 2024. Support, Print Operations, and all other functions will resume on Tuesday, September 3.
Posted Aug 28, 2024 - 18:47 UTC
This incident affected: Supporting Services (Parchment Print, Parchment Support).