Login Issues

Incident Report for Parchment Inc

Resolved

This incident has been resolved. We will continue to monitor site activity.
Posted Sep 10, 2026 - 21:45 UTC

Investigating

We are currently investigating an issue with users getting an error logging into the website.
Posted Sep 10, 2026 - 21:19 UTC
This incident affected: Parchment Award - Transcript Services and Parchment Award - Diploma, Certificate, Badge, CLR.