Parchment Closed 6/19/2024

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Jun 20, 2024 - 14:08 UTC

Investigating

Parchment will be closed on June 19, 2024. Parchment Support will reopen at 8am eastern on Thursday June 20, 2024.
Posted Jun 13, 2024 - 16:39 UTC
This incident affected: Supporting Services (Parchment Support).