GED Ordering Delays

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 20:18 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 11, 2026 - 20:18 UTC

Monitoring

We are aware of a delay with processing orders for GED customers and are monitoring the situation.
Posted Mar 11, 2026 - 16:54 UTC
This incident affected: Parchment Award - Transcript Services.