Credentials-Inc Service Interruption
Incident Report for Parchment Inc
Resolved
Service has been restored to the credentials-inc platform.
Posted Aug 21, 2024 - 13:21 UTC
Investigating
Parchment is aware of a service interruption with the credentials-inc platform and is investigating to restore service. More details to follow.
Posted Aug 21, 2024 - 12:33 UTC