Parchment Website Returning 404 Error

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 16:37 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2025 - 15:58 UTC

Identified

Issue has been identified as an account update made for the Wordpress site and we are working to rectify with support.
Posted Feb 10, 2025 - 15:02 UTC

Investigating

We are currently investigating the issue. There is no known impact to ordering and issuing services.
Posted Feb 10, 2025 - 13:45 UTC