Delay with files coming into Parchment
Incident Report for Parchment Inc
Resolved
This incident has been resolved.
Posted Aug 20, 2024 - 22:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 20, 2024 - 22:07 UTC
Investigating
We are currently investigating reports of files not appearing within Parchment once they are sent.
Posted Aug 20, 2024 - 20:56 UTC
This incident affected: Parchment Award - Transcript Services.