Company Wide Meeting (5/10)
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted May 10, 2022 - 18:13 PDT
Identified
Parchment Phone Support will be temporarily unavailable from 4:45 PM CST - 6:00 PM CST today for a company wide meeting. We apologize for the inconvenience. We will respond to your inquiries as soon as possible.
Posted May 10, 2022 - 06:16 PDT
This incident affected: Credentials Solutions (TranscriptsPlus, eScrip-Safe), Parchment 7 (Administrator (Login & Processing), Learner (Login, Registration & Ordering)), Parchment 6 (Administrator (Login & Processing)), Consumer (Learner (Login, Registration & Ordering), Administrator (Login & Processing)), and Parchment Analyze, Parchment Award.