Regular Maintenance

Incident Report for Parchment Inc

Resolved

Maintenance has been completed.
Posted Mar 28, 2026 - 19:17 UTC

Update

We are continuing to investigate this issue.
Posted Mar 28, 2026 - 19:16 UTC

Investigating

We will be undergoing scheduled maintenance during this time.
Posted Mar 28, 2026 - 16:02 UTC
This incident affected: Consumer (Login, Ordering, Payment / JPMChase), Integrations (Ellucian eTranscripts, eScrip-Safe Printer, RoboRegistrar), Supporting Services (FedEx, USPS, Parchment Print, Parchment Support, Salesforce / Parchment Help Center, GlobalSign), Parchment Award Document Management (Annotation Services, Document Import Services, Search Clusters & NoSQL Storage, Viewer), Parchment Pathways K-12 District Transfer (Email Notification Service, Search Clusters & NoSQL Storage, SMS & Phone Services), Parchment Pathways K-12 Enroll (Email Notification Service, GIS Integration, Search Clusters & NoSQL Storage, SMS & Phone Services), Parchment Pathways K-12 Lottery (Email Notification Service, GIS Integration, Search Clusters & NoSQL Storage, SMS & Phone Services), ScribOrder (Credit Card Processing, Email Notification Service, IP Printing & Digital Signing, ScribCheck, SMS & Phone Services, Search Clusters & NoSQL Storage, Etrans System), and Parchment Award - Transcript Services, Parchment Award - Diploma, Certificate, Badge, CLR, Parchment Analyze/Recruit, Course and Credit Solutions (Quottly) - Web Application, Course and Credit Solutions (Quottly) - Integration.