Parchment.com, NeedMyTranscript.com redirection inconsistency

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Nov 22, 2025 - 05:28 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 21, 2025 - 21:16 UTC

Identified

We are investigating an issue where traffic requests starting at either parchment.com or needmytranscript.com (without www.) is inconsistently redirecting. Traffic to www.parchment.com should continue to function as expected. We will post more info as it becomes available.
Posted Nov 21, 2025 - 15:52 UTC
This incident affected: Consumer (Login).