Page does not load when attempting to place a SAIR or RAIR order

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted May 06, 2026 - 22:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 05, 2026 - 18:24 UTC

Identified

We have identified an issue that causes the page to spin when you click the order tab in your account. This is an intermittent issue and you can attempt to place the order again.
Posted May 05, 2026 - 16:41 UTC
This incident affected: Parchment Award - Transcript Services.