Award Order Processing Delays

Incident Report for Parchment Inc

Monitoring

Award jobs are now processing nominally, we will continue to monitor the situation.
Posted Oct 22, 2025 - 20:22 UTC

Investigating

We are investigating an issue where orders are successfully submitted but not processing, we will provide more information as it becomes available.
Posted Oct 22, 2025 - 13:38 UTC
This incident affects: Parchment Award - Transcript Services and Parchment Award - Diploma, Certificate, Badge, CLR.