Robo service interruption
Incident Report for Parchment Inc
Resolved
The issue connecting to our Robo service is now resolved.
Posted Jun 04, 2024 - 11:02 UTC
Investigating
We are investigating an issue that is resulting in delays processing credentials for Robo users
Posted Jun 04, 2024 - 08:35 UTC
This incident affected: Integrations (RoboRegistrar).